Fire Pro Wrestling World Save Tool – Manual

Manual for v1.0.8.0 (2017/10/15; October 15, 2017)
Program and Manual written by freem

Table of Contents

  1. Introduction
  2. Known Issues
  3. Main Window
  4. Save Data Sections
    1. Options
    2. Controls
    3. Statistics
    4. Edit Wrestlers
    5. Edit Referees
    6. Edit Rings
    7. Organizations and Groups
    8. Wrestler Display Order
    9. Move Names
    10. Titles
    11. Achievements
    12. Missions
    13. Workshop
  5. Importing Wrestlers from Fire Pro Wrestling Returns
    1. Notes and Limitations
    2. Exporting .fpwedit Files
    3. Importing .fpwedit Files
  6. Progress Data
  7. Database Sections
    1. Author Database
    2. Item Authors
  8. Changelog
  9. Credits

Introduction

The Fire Pro Wrestling World Save Tool is a program for viewing and manipulating the data found in Fire Pro World save files.


The Save Data

ALWAYS MAKE BACKUPS!! This is recommended advice regardless of mod/tool usage.

Fire Pro Wrestling World's save data is stored by default in a folder matching this pattern:

C:\Users\(username)\AppData\LocalLow\spikechunsoft\FireProWrestlingWorld\

The file you'll want to open is called "savedata.dat". In fact, before you even decide to open the save data in the editor, you'll want to make a backup of it. Don't save it in the same folder, though; Steam likes to pick up any similarly named file and store it in the Cloud, which can deprive you of storage space.

Do not open the save in the editor while the game is running.

Another note is that as of game version 0.9010, the save data structure has changed. If you have a save from game version 0.9009 or earlier, please load it in game version 0.9010 (or later) before using it with this program. This program lacks the necessary failsafe routines to upgrade the save data for you.

Save Data Version Information

Game Version Save Version Notes
0.9000 to 0.9004 0 Original save data format.
0.9005 1 First major update of the save data structures.
  • Game Options: Added Screen Resolution option.
  • Match Options: Array size 800 → 1000 (for S-1 mode).
  • Edit Wrestlers: Added Texture Cache ID, Invalidate Texture Cache flag.
0.9006, 0.9007 2
  • Edit Wrestlers: Added Theme Music Filename string.
0.9008, 0.9009 3
  • Game Options: Added Cache option.
  • Ring Data: Added three String members.
0.9010 4
  • Game Options: Added Crowd Volume option.
  • Appearance Data: Expanded body part scale values from 5 entries to 9.
  • Edit Wrestlers: Expanded priority slot count from 3 entries to 10.

The Progress Data

Progress data is generated when you save a Tournament or League in-game. The file that gets created is called fpw_progress.dat, and it is located in the game's executable folder.


Known Issues

The following issues with the program are known:


Main Window

Upon opening the program, the Main Window appears. This is the main control point of the program, where you can open, close, and write changes to save data. It also contains menus leading to the save data information, progress data, and item databases, which are explained in later sections.

Opening the Save File

There are three ways to open the save data file:

  1. Via the File menu ("File", "Open Save Data..."); keyboard shortcut Control+O
  2. Dragging the save data file onto the main form.
  3. Dragging the save data file onto the program icon, or adding the path to the save file after the executable name on the command line.

Upon opening a save file, a dialog may appear; this is related to the save version number. If the save version number is lower than the current known version, you will be asked to load the save file in Fire Pro World to update it to the latest version.

However, if the save number is higher than the current known version, the program will let you know that editing the save file is not safe. If this is the case, please wait for freem to provide an updated version of the Save Tool before making any changes.

After opening a file, the Main Window changes:

The text box in the middle contains various information about the save data, including save chunk information. The status bar text is replaced with the location of the opened save data file.


Save Data Sections

Once a save file is opened, the "Save Data" menu item is enabled. This menu provides access to various sections of the save data.


Options

View and change Fire Pro Wrestling World's game options. The options are split into two different groups: Main Options and Sound Options.

Main Options

Sound Options

When opening earlier save versions, some options are not available.


Controls

The Controls dialog allows you to view the control mappings for controllers and the keyboard. Where available, button equivalents for Saturn, Playstation, and Xbox controllers are shown.

Mappings can not be changed through this program; it's better to change controller mappings in-game.

Controller

Up to eight controller mappings are stored in the save data. The "Controller GUID" value is a unique identifier for the controller being used.

Keyboard

The Keyboard tab lists the active control mappings for the keyboard. Not every scan code has a matching string, sadly. That's part of why this is incomplete.


Match Settings

The Match Options are going to take a while to fix... Some values are decoded properly, but others aren't mapped to the options yet.

The available match types change based on the save version (S-1 Rules Match was added in save version 1).

The Battle Royal tab values may not be correct. Approach with caution.


Statistics

Fire Pro Wrestling World keeps track of a number of statistics. These include:

The last four items are related to the creation of ID values for various items. An accurate count for each group of data is also provided.


Edit Wrestlers

The Edit Wrestler dialog shows information for the wrestlers in the save.

Right clicking the Skills, Parameters, Moveset, and CPU Logic buttons displays a context menu, which can be used to copy and paste these items to other edit wrestlers.

Clone

The Clone button clones the currently selected wrestler to a new slot.

Delete

Deletes the currently selected wrestler from the local data. DOES NOT REMOVE WORKSHOP SUBSCRIPTION. See the Workshop section of the manual for more information.

Import

The Import button allows you to import wrestlers from Fire Pro Wrestling Returns, using .fpwedit files generated by the "Fire Pro Wrestling Returns Wrestler Tool" written by freem.

More information about importing wrestlers can be found in the "Importing Wrestlers from Fire Pro Wrestling Returns" section.

Delete

Deletes the currently selected wrestler from the local data. As of version 1.0.5.1, local subscription data is removed for Workshop wrestlers.

Find

The Find button allows you to search for wrestlers in your save file via text. In the current version, the search covers the wrestler's display name, as well as their Workshop item title (if one exists; Subscribed items only). Japanese IME support is highly recommended for searching in Japanese.

View Hashes

The "View Hashes" button pops up a dialog showing SHA256 hashes for various parts of the Edit Wrestler, as well as a SHA256 hash for the overall wrestler data. Two export options are available: just the main hash, or all of the hashes in the dialog. Both end up as simple text files.

This feature has a few uses that aren't immediately obvious:

A new feature in v1.0.3.0 is the ability to check for the default model wrestler's skills, parameters, moveset, and logic. When the hash of an edit wrestler for a specified section matches the hash for the default wrestler's data in the same section, the background of the relevant hash box turns salmon.

This is what an Appearance-only edit looks like (some values blocked out to protect the guilty party). If you see this, it's probably best to either delete the wrestler or clone and overhaul it.

Profile

The Profile dialog contains basic information about the wrestler.

Name Info
Profile Info

Appearance

Clicking the Appearance button brings up the Appearance dialog. As it's still a work in progress, not everything can be edited. The exact same dialog is used for Referee appearances.

Shared
Scale

Fire Pro World v0.9010 expanded the scale values from five entries to nine. Since the amount of work required to allow for editing both versions of the scale is too much, the new Appearance dialog only works with newer save data.

Costume Sections

From left to right, the values for each part of the costume are as follows:

Color panels can be right clicked to display a context menu, allowing for copying and pasting of colors.

Import Appearance

Pressing the "Import..." button brings up a file dialog. The file format drop down box gives a choice between three formats:

Depending on what format is being imported, one of two dialogs will appear.

Import Appearance (.fpwapx, xcos)

When selecting an .fpwapx file or an xcos format file, the default Import Appearance dialog appears:

The Import Appearance dialog can be a bit tricky to deal with if you haven't seen it before. Notes about the costume appear in the Notes box (if the imported costume format supports them).

The top left portion of the dialog determines which costumes to import (via checkboxes), as well as what slot to import them to (represented with drop down boxes).

The middle-bottom portion of the dialog allows you to pick separate body parts to import. Dealing with these checkboxes can be tricky.

Once you've finished selecting what costumes to import, as well as the body parts to use, press the "Import Appearances" button to perform the importing.

It should be noted that attempting to import costumes into multiple slots out of order will re-order them. You will need to use the "Swap Costumes" feature to fix the appearance order.

Import Appearance (.fpwedit)

When selecting an .fpwedit file, the Save Tool attempts to convert the wrestler's appearance to Fire Pro World. Please see the Notes and Limitations section of Chapter 5 ("Importing Wrestlers from Fire Pro Wrestling Returns") for more information on Fire Pro Returns appearance importing.

After selecting a slot to import the costume into, press the "Import" button to import the costume.

Export Appearance

Select which costumes you'd like to export on the left hand side, then write some notes about the exported costumes in the Notes box. Finally, hit the Export button, and save the file. (Preferably using the Fire Pro Wrestling Save Tool format, so your notes get saved.)

Swap Costumes

The Swap Costumes button allows you to swap two costume slots. This feature primarily exists to counter-act the Import Appearance's failsafe feature, which will sometimes re-order your costume imports.

Skills

View and change the wrestler's skills here.

Custom theme music from Save Version 1/Game Version 0.9005 (based on indices) is not supported. Custom theme music from Save Version 2/Game Version 0.9006 (based on filenames) is supported.

Parameters

View and change the wrestler's parameters here.

Moveset

View the wrestler's moveset, and change certain aspects of it. Also has a spot to change the finisher name.

Only the Voice, Signature/Finisher flags, and Finisher Name can be edited. You can only have one Finisher, and up to four Signature moves.

Voice Values
  1. No Voice
  2. Voice 1
  3. Voice 2

CPU Logic

Read-only CPU Logic dialog. Can't change anything here, sorry.


Edit Referees

Referee data can be viewed and changed here.

Information
Parameters

Pressing the "Appearance Data..." button will bring up the Appearance dialog. The Appearance dialog is the same as the one used for Edit Wrestlers, except the stance is locked to Referee, and only the first costume is saved.

The buttons under the Referee list:


Edit Rings

The Edit Ring section of the program is pretty similar to freem's stand-alone ring editor. The only difference at the moment is that the Date value does not get modified when a ring is changed.

Ring List Buttons

Ring Information

Design Elements

Colors

The Colors section is split into four parts.

Left clicking on a color panel will open a color editor.

Right clicking on a color panel displays a context menu with three options. Copy and Paste allows you to use the same color in multiple places. The "Custom Texture Fix" option resets the specified color to white, so the texture is displayed without any tinting. This is primarily used with Carlzilla's custom mat/turnbuckle texture modification.

Texture Filenames

In game version 0.9008, three strings were added to the Edit Ring data structure. While the game does not currently use them, the boxes are provided for future use. Since they are not yet used, the purpose of each string is unknown.


Organizations and Groups

The Organizations and Groups dialog is your new best friend. The "Retired" section is displayed as "未登録" in this program, since that's what the save data actually contains for those sections.

You can re-order groups and organizations (that aren't the Retired section) nearly anywhere by dragging and dropping them. Since the default TreeView control doesn't provide a nice insertion mark, trying to drag an item to the top of a section can be painful.

If moving a Group to the top of an Organization list, drag the Group item onto the target Organization. You can not move an organization above the Retired organization.

Org/Group Information

The top portion of the right hand side of the dialog allows you to view and edit information about the selected group or organization.

Member Wrestlers

The "Member Wrestlers" section of the dialog lists all of the wrestlers in the selected organization or group. If a wrestler is a Workshop wrestler, the subscribed item title will appear after their name. Select whichever wrestlers you'd like to move using the mouse (hold Control to toggle a selection anywhere in the list without losing the current selection), then press the "Move Wrestlers" button.

Move Wrestlers

The Move Wrestlers dialog appears once you've selected wrestlers to move. Their current location is noted at the top. The wrestlers to be moved are in the middle; they can't be changed at this point (this could change in future versions). The bottom of the dialog contains the Destination Group option, which is where the wrestlers will be moved to. Pressing the "Move Wrestlers" button will perform the move.

Add New...

The "Add New..." button allows you to create new organizations and groups. By default, it brings up the organization section of the dialog:

After pressing OK, the new organization will be added to the bottom of the list in the main Organizations and Groups dialog.

If you wish to make a new group, select the "Group" radio button; the dialog will change appearance:

After pressing OK, the new group will be added to the list in the main Organizations and Groups dialog.


Wrestler Display Order

The Wrestler Display Order dialog allows you to re-order the wrestlers. Two options are given for dealing with the list: "List Order" and "Grouped by Org/Group". No matter which option is selected, the dialog acts the same.

Drag and drop the wrestlers to re-order them. You will not be able to put someone at the top of the list, so drag them to the top entry, then swap the top two items. This may be changed in the future, as it has the same problems as the TreeView in the Organizations and Groups dialog.

Selecting a wrestler provides various information:

If the wrestler is a Workshop wrestler, the following fields appear:

The "View in Wrestler Dialog..." button is only usable with Local and Workshop wrestlers. When clicked, it will open the Edit Wrestler dialog with the selected wrestler's information.

Re-Sort

The program is capable of re-ordering your wrestlers automatically based on certain criteria.

Alphabetical sorting support is considered incomplete, since it does not attempt to take Japanese character order into account.

List Order

The "List Order" option orders the wrestlers by the actual values in the save file. This is similar to what you get in the in-game Sort Wrestlers interface.

Grouped by Org/Group

The "Grouped by Org/Group" limits the available wrestlers to a specific group, based on the group chosen in the dropdown box.


Move Names

Fire Pro Wrestling World allows you to globally rename moves. This is useful if you find that the new default move names aren't memorable enough. However, these values are best set in the game itself, so this section is read-only.


Titles

View and edit information about Title belts.

Information

Design Elements

Color panels can be right clicked to display a context menu, allowing for copying and pasting of colors. Since there are only two colors though, this is mostly pointless.

Match Conditions

Current Champion(s)

View information about the current holder(s) of this title.

View Match Options

Clicking the "View Match Options..." button brings up the Title Match Options dialog. The data in this dialog is read-only. Most values are decoded at this point, though the Arena is an exception.

Title History

Upon clicking the "View Title History..." button, the Title History dialog appears. Information about the current and previous belt holders can be viewed.


Achievements

Displays achievement unlock status as stored in the save file. Values are not editable and may not be up to date with Steam servers.


Missions

Displays mission clear status. Values are not editable, since this program is made by one of the 7 people who actually plays the game from time to time. ;D


Online Records

Displays the online records associated with this save file. Values are not editable.


Workshop

The Workshop portion of the program handles the Steam Workshop information contained in the save file. Workshop information is separated into three categories: Published Items, Subscribed Wrestlers, and Subscribed Referees.

Published Items

The Published Items section contains information on the wrestlers and referees you've published to the Steam Workshop.

Subscribed Wrestlers

The Subscribed Wrestlers tab shows all of your subscribed wrestlers (according to the save file, anyways).

Subscribed Wrestler Information
Local Wrestler Information
Buttons

Neither of these buttons updates the subscription data on the Steam servers.

Subscribed Referees

The Subscribed Referees portion of the dialog works similar to the Subscribed Wrestlers section.


Subscription Manager

The Subscription Manager allows you to remove multiple subscriptions from the local save data in one action. Optionally, you can delete the local data that goes along with it. However, this does not update the information on Steam's servers, so if you haven't unsubscribed from the item, it will be redownloaded upon launching the game.


Update Author...

Both the Subscribed Wrestlers and Subscribed Referee tabs allow you to update the author information stored in the program's databases.

The Item Title, Item Type, and Workshop ID are displayed, followed by a dropdown box containing the existing authors, as well as the "Add New Author..." button, and the standard OK/Cancel buttons.

If you know the author already exists in the author database, select their entry from the dropdown box. Otherwise, press the "Add New Author..." button and read the next section.

Add Author

Adding an author requires you to know their Steam User ID. To obtain the Steam User ID value, you can plug in a user name or profile URL to the calculator on SteamDB. Copy the number found next to "SteamID", and paste it into the "Steam ID" textbox. After doing so, enter a more familiar name in the "Author Name" textbox and press the OK button. The author will be added to the end of the dropdown box's list in the Update Author dialog.


Database Sections

As Fire Pro Wrestling World does not provide a method of mapping Workshop items to Authors, trying to manage a collection gets tricky.


Author Database

The Author Database section of the program provides an interface for mapping Steam User ID numbers to more familiar names. To add an entry, scroll to the end of the list, then double click on the empty cell in the "Steam ID" column.

To obtain the Steam User ID value, you can plug in a user name or profile URL to the calculator on SteamDB. Copy the number found next to "SteamID", and paste it into the cell in the "Steam ID" column. After doing so, enter a more familiar name in the cell next to the one you entered the Steam User ID into.


Item Authors

The Item Authors database window handles mapping Workshop item IDs to the Author IDs found in the Author Database. It is provided to give a view of the entire list at once, and is not particularly user-friendly. Adding and editing items via the grid view is not recommended, as the Workshop dialog provides better tools for managing item authors.

Add Item

Version 1.0.6.0 adds an "Add Item" button, which allows you to enter data for an item you may not particularly have downloaded.


Importing Wrestlers from Fire Pro Wrestling Returns

Version 1.0.5.0 of the Fire Pro World Save Tool introduces the ability to import wrestlers from Fire Pro Returns, by way of the Fire Pro Returns Wrestler Tool.


Notes and Limitations

THIS SECTION IS IMPORTANT. Please read it.

Since Fire Pro Wrestling World made a number of changes under the hood, not every wrestler imported from a .fpwedit file will be perfect.

Here are a list of notes and known issues related to importing wrestlers from Returns:


Exporting .fpwedit Files

In order to follow these steps, you will need to download the latest version of the Fire Pro Wrestling Returns Wrestler Tool. Some steps are not explained in detail here; please read the manual for the Fire Pro Returns Wrestler Tool for detailed information on program usage.

The first step (after extracting the save file required by the Returns Wrestler Tool) is to open the save in the Returns Wrestler Tool.

Exporting a Single Wrestler

If you only want to export one wrestler at a time, first select the wrestler you want to export in the interface using the "Wrestler Slot" combo box:

Once you've selected the wrestler, select "Wrestler"→"Export Wrestler Data" from the menu. This will bring up the export dialog:

Within the Export dialog, you can set the edit author's name (if you know it; if not, leave it blank) and provide any notes about the edit. Anything stored in the Notes box will be shown during the import process in the Fire Pro World Save Tool. Press the "Export..." button to bring up a save file dialog, then save the file and head to "Importing .fpwedit Files".

Exporting Multiple Wrestlers

If exporting the wrestlers one by one seems too tedious, there is an option to export multiple wrestlers at once (as of Returns Wrestler Tool v0.0.2.1). The format of each line is:

Slot ID: Wrestler Display Name (Nickname) (Bio Line 1 Bio Line 2)

The mass export dialog contains a few drawbacks, however...


Importing .fpwedit Files

After exporting .fpwedit files from the Fire Pro Returns Wrestler Tool, they can be imported in the Fire Pro World Save Tool via the "Import" button in the Edit Wrestler dialog. Pressing the button brings up an open file dialog. Select one or more .fpwedit files for the wrestler(s) you want to import. After clicking "Open", one of two dialogs will appear, depending on how many wrestlers were selected.

Single Import

Importing a single .fpwedit file gives you this screen:

This dialog allows you to see some information about the wrestler to be imported.

Upon pressing the "Import" button, the wrestler will be added to the save data as a local wrestler (meaning you can edit them in-game). Similar to bringing someone over from a save in Fire Pro Returns, the imported wrestler will end up in the "Retired" section.

Mass Import

Importing multiple .fpwedit files gives you this screen:

The columns of the grid are as follows:

Upon pressing the "Import" button, the wrestler will be added to the save data as a local wrestler (meaning you can edit them in-game). Similar to bringing someone over from a save in Fire Pro Returns, the imported wrestler will end up in the "Retired" section.


Progress Data

As of version 1.0.4.0, the Fire Pro Wrestling World Save Tool can read Tournament and League progress data. Making sense of it is not exactly easy, however.

Disable Progress Data Checks

This setting allows the program to skip any tournament/league checks that are normally required when deleting wrestlers, referees, rings, and titles.

This option should be enabled/checked if you have no tournament or league progress data.

Tournament

Of the two types of Progress data, Tournament data is more well understood.

League

League Progress data is not nearly as well understood, and the UI was hacked together just to put something there.


Changelog

For the time being, changelog information is found in "changelog.txt".


Credits

Program and Manual by freem

Special Thanks

(in no particular order)


This program is not endorsed, sponsored, or developed by Spike Chunsoft, ZEX Corporation, or anyone else involved in the development of Fire Pro Wrestling World.

Use at your own risk. ALWAYS MAKE BACKUPS.